Back to overview
Degraded
Analytics: Performance degradation
May 18 at 09:44am UTC
Affected services
Handpoint Transaction Feed API
Resolved
May 18 at 10:16am UTC
We've mitigated the elevated load that was affecting the analytics database. Dashboards and queries have been operating normally since 10:10 UTC. We're continuing to monitor the service closely and do not anticipate further impact.
Affected services
Handpoint Transaction Feed API
Created
May 18 at 09:44am UTC
We are currently seeing a sustained spike in CPU utilization on the analytics database cluster. This may lead to slower‑than‑normal query performance and delays in analytics dashboards. Our engineering team is actively investigating the root cause and working on mitigation.
Affected services
Handpoint Transaction Feed API