Back to overview
Downtime

Global Outage

Apr 28 at 09:03pm UTC
Affected services
Handpoint Cloud API
Handpoint In-person/Card Present Gateway
Handpoint online/Card Not Present Gateway
Handpoint Payments app API
Handpoint Transaction Feed API
Altron
Amex Direct
EmerchantPay
EVO
Interac
Lloyds
Omnipay
Paysafe
Paystrax
Teya (Saltpay)
TNS
TSYS
Worldpay/Vantiv

Resolved
Apr 28 at 10:45pm UTC

We can confirm that connectivity has been partially restored to AWS via at least one connection point. While service remains intermittent, we’re now seeing transactions successfully process. At this stage, it’s unclear why on-site backup generators were unable to maintain connectivity—this unprecedented outage appears to have overwhelmed Spain’s network backbone and severed links to the wider internet. Our team is monitoring the link continuously and will inform you once full, stable connectivity is re-established.

Created
Apr 28 at 09:03pm UTC

Power outage has affected AWS DirectConnect in Spain which impacts Handpoint’s ability to process. This looks to be a Force Majeure event that is unfortunately completely out of our hands to control or say when power will be restored. It looks like we are beholden to Spain’s ability to resolve the power crisis.