Back to overview
Degraded
TMS Analytics is failing to load the list of processed transactions
Apr 13, 2026 at 7:11am UTC
Affected services
Handpoint Transaction Feed API
Resolved
Apr 13, 2026 at 7:43am UTC
TMS Analytics is now fully operational and showing the history of processed transactions. We apologize for any inconvenience.
Affected services
Created
Apr 13, 2026 at 7:11am UTC
We are currently investigating an issue where TMS Analytics is failing to load the list of processed transactions. Our engineering team is working to restore service as quickly as possible.
Note this is NOT affecting transaction processing nor transactionFeed API.
Affected services