Back to overview
Degraded

TMS Web Analytics not listing transactions

Apr 10, 2026 at 7:53am UTC
Affected services
Handpoint Transaction Feed API

Resolved
Apr 10, 2026 at 8:22am UTC

The issue affecting TMS Analytics has been resolved, and the list of processed transactions is now loading correctly. We apologize for the disruption and appreciate your patience while we worked through this

Created
Apr 10, 2026 at 7:53am UTC

We are currently investigating an issue where TMS Analytics is failing to load the list of processed transactions. Our engineering team is working to restore service as quickly as possible.

In the meantime, you can access transaction data by logging into merchant.portal.com using your unique merchant email address.

Payment processing is not affected and transactionFeed API is not affected either, it's only on TMS Web Analytics