Back to overview
Degraded

Transactions Impacted | AWS Degraded

Oct 20 at 07:31am UTC
Affected services
Handpoint In-person/Card Present Gateway

Resolved
Oct 20 at 09:22am UTC

Update: We are seeing significant recovery. Most payment authorizations are now succeeding. AWS reports most requests in US-East (N. Virginia) are succeeding, with ongoing work to process backlogs. Some residual latency or intermittent failures may persist during catch-up.

Updated
Oct 20 at 09:13am UTC

Update: AWS US-East (N. Virginia) incident continues to impact our services. AWS has identified a potential root cause related to DNS resolution for the DynamoDB API in us-east-1 and is working on multiple paths to accelerate recovery. As a result, payment authorizations may fail or time out.

Updated
Oct 20 at 08:40am UTC

Update: We are continuing to see elevated failures and timeouts for payment authorizations due to an ongoing AWS US-East (N. Virginia, us-east-1) incident impacting multiple services (including DynamoDB).
TMS Web and Analytics are not impacted.

Created
Oct 20 at 07:31am UTC

We’re investigating an issue with AWS Virginia that is impacting on our transactions and systems. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.