Back to overview
Degraded
Handpoint has identified connection errors with the 3-D Secure service for Visa
Sep 21 at 08:28am UTC
Affected services
Handpoint online/Card Not Present Gateway
Resolved
Sep 21 at 09:02am UTC
Handpoint can confirm that connections with the 3-D Secure service for Visa have returned to normal.
Affected services
Handpoint online/Card Not Present Gateway
Created
Sep 21 at 08:28am UTC
Our engineers are investigating, and we will provide an update within the next hour.
Affected services
Handpoint online/Card Not Present Gateway